1 Star 0 Fork 10

AGIROS_Team/python-scp

forked from src-openEuler/python-scp 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-scp.spec 3.24 KB
一键复制 编辑 原始数据 按行查看 历史
dongQ 提交于 2024-08-02 10:05 +08:00 . !14 Update to 0.15.0
%global _empty_manifest_terminate_build 0
Name: python-scp
Version: 0.15.0
Release: 1
Summary: scp module for paramiko
License: LGPL-2.1-or-later
URL: https://github.com/jbardin/scp.py
Source0: https://files.pythonhosted.org/packages/d6/1c/d213e1c6651d0bd37636b21b1ba9b895f276e8057f882c9f944931e4f002/scp-0.15.0.tar.gz
BuildArch: noarch
%description
The scp.py module uses a paramiko transport to send and recieve files via the
scp1 protocol. This is the protocol as referenced from the openssh scp program,
and has only been tested with this implementation.
%package -n python3-scp
Summary: scp module for paramiko
Provides: python-scp = %{version}-%{release}
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
%description -n python3-scp
The scp.py module uses a paramiko transport to send and recieve files via the
scp1 protocol. This is the protocol as referenced from the openssh scp program,
and has only been tested with this implementation.
%package help
Summary: Development documents and examples for scp
Provides: python3-scp-doc
%description help
The scp.py module uses a paramiko transport to send and recieve files via the
scp1 protocol. This is the protocol as referenced from the openssh scp program,
and has only been tested with this implementation.
%prep
%autosetup -n scp-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.rst ]; then cp -af README.rst %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.md ]; then cp -af README.md %{buildroot}/%{_pkgdocdir}; fi
if [ -f README.txt ]; then cp -af README.txt %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
# check fail for ssh server has no authentication methods available
#%{__python3} setup.py test
%files -n python3-scp -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jul 30 2024 dongqi <dongqi1@kylinos.cn> - 0.15.0-1
- Update package to version 0.15.0
Fix limit_bw default and Use limit_bw in some tests
* Wed Mar 22 2023 wangjunqi <wangjunqi@kylinos.cn> - 0.14.5-1
- Update package to version 0.14.5
* Thu Jun 09 2022 OpenStack_SIG <openstack@openeuler.org> - 0.14.4-1
- Upgrade package python3-scp to version 0.14.4
* Fri Aug 06 2021 OpenStack_SIG <openstack@openeuler.org> - 0.13.3-1
- Upgrade version to 0.13.3
* Fri Mar 12 2021 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/AGIROS_Team/python-scp.git
git@gitee.com:AGIROS_Team/python-scp.git
AGIROS_Team
python-scp
python-scp
master

搜索帮助