1 Star 0 Fork 3

brucezhang/libdnf

forked from OpenCloudOS Stream/libdnf 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
libdnf.spec 4.16 KB
一键复制 编辑 原始数据 按行查看 历史
Summary: Package management library
Name: libdnf
Version: 0.70.2
Release: 6%{?dist}
License: LGPLv2+
URL: https://github.com/rpm-software-management/libdnf
Source0: https://github.com/rpm-software-management/libdnf/archive/%{version}/%{version}.tar.gz
Patch0001: 0001-get_best_selectors-only-obsoleters-of-latest.patch
BuildRequires: cmake gcc gcc-c++ libsolv-devel >= 0.7.21 librepo-devel check-devel glib2-devel
BuildRequires: sqlite-devel json-c-devel cppunit-devel openssl-devel libmodulemd-devel libsmartcols-devel gettext gpgme-devel
Requires: libmodulemd libsolv >= 0.7.21 librepo
%global libdnf_major_version $(echo %{version} | cut -d '.' -f 1)
%global libdnf_minor_version $(echo %{version} | cut -d '.' -f 2)
%global libdnf_micro_version $(echo %{version} | cut -d '.' -f 3)
%description
This library provides a high level package-manager. It's core library of dnf,
PackageKit and rpm-ostree. It's replacement for deprecated hawkey library
which it contains inside and uses librepo under the hood.
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}-%{release}
Requires: libsolv-devel >= 0.7.21
%description devel
Development files for %{name}.
%package -n python3-%{name}
Summary: Python 3 bindings for the libdnf library.
BuildRequires: python3-devel swig
Requires: %{name} = %{version}-%{release}
Provides: python%{python3_version}-%{name} = %{version}-%{release}
Provides: python-%{name} = %{version}-%{release}
%description -n python3-%{name}
Python 3 bindings for the libdnf library.
%package -n python3-hawkey
Summary: Python 3 bindings for the hawkey library
BuildRequires: python3-devel
Requires: %{name} = %{version}-%{release}
Requires: python3-%{name} = %{version}-%{release}
Provides: python%{python3_version}-hawkey = %{version}-%{release}
Provides: python-hawkey = %{version}-%{release}
%description -n python3-hawkey
Python 3 bindings for the hawkey library.
%prep
%autosetup -p1
%build
mkdir build
pushd build
%cmake -DPYTHON_DESIRED:FILEPATH=%{__python3} -DWITH_GIR=0 -DWITH_MAN=0 -DWITH_HTML=0 -DWITH_GTKDOC=0 -DWITH_ZCHUNK=OFF -DDISABLE_VALGRIND=1 -DLIBDNF_MAJOR_VERSION=%{libdnf_major_version} -DLIBDNF_MINOR_VERSION=%{libdnf_minor_version} -DLIBDNF_MICRO_VERSION=%{libdnf_micro_version} -DWITH_SANITIZERS=0 ../
pushd %{_vpath_builddir}
%make_build
popd
popd
%install
pushd build/%{_vpath_builddir}
%make_install
popd
%find_lang %{name}
%check
pushd build/%{_vpath_builddir}
make ARGS="-V" test
popd
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files -f %{name}.lang
%license COPYING
%doc README.md AUTHORS
%{_libdir}/%{name}.so.*
%{_libdir}/libdnf/plugins/README
%dir %{_libdir}/libdnf/
%dir %{_libdir}/libdnf/plugins/
%files devel
%{_libdir}/%{name}.so
%{_libdir}/pkgconfig/%{name}.pc
%{_includedir}/%{name}/
%files -n python3-%{name}
%{python3_sitearch}/%{name}/
%files -n python3-hawkey
%{python3_sitearch}/hawkey/
%changelog
* Thu Mar 27 2025 bbrucezhang <bbrucezhang@tencent.com> - 0.70.2-6
- [Type] other
- [DESC] hawkey.subject: get_best_selectors only obsoleters of latest
* Thu Sep 26 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.70.2-5
- Rebuilt for clarifying the packages requirement in BaseOS and AppStream
* Fri Aug 16 2024 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.70.2-4
- Rebuilt for loongarch release
* Tue Sep 19 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.70.2-3
- Rebuilt for python 3.11
* Fri Sep 08 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.70.2-2
- Rebuilt for OpenCloudOS Stream 23.09
* Tue Aug 22 2023 cunshunxia <cunshunxia@tencent.com> - 0.70.2-1
- upgrade to 0.70.2
* Tue Jul 11 2023 Yi Lin <nilusyi@tencent.com> - 0.69.0-1
- upgrade to 0.69.0
* Fri Apr 28 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.67.0-3
- Rebuilt for OpenCloudOS Stream 23.05
* Fri Mar 31 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 0.67.0-2
- Rebuilt for OpenCloudOS Stream 23
* Fri Apr 29 2022 Xun Zhong <victorzhong@tencent.com> - 0.67.0-1
- init build
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/bbrucezhang/libdnf.git
git@gitee.com:bbrucezhang/libdnf.git
bbrucezhang
libdnf
libdnf
master

搜索帮助