1 Star 0 Fork 43

chengquan/python-flask

forked from src-openEuler/python-flask 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-flask.spec 2.54 KB
一键复制 编辑 原始数据 按行查看 历史
jinjin 提交于 2020-03-07 15:26 +08:00 . add
Name: python-flask
Version: 1.0.4
Release: 3
Epoch: 1
Summary: A lightweight WSGI web application framework
License: BSD
URL: https://palletsprojects.com/p/flask/
Source0: https://files.pythonhosted.org/packages/source/F/Flask/Flask-1.0.4.tar.gz
BuildArch: noarch
BuildRequires: python2-sphinx
BuildRequires: python2-devel python2-setuptools python2-pytest python2-jinja2 python2-werkzeug python2-itsdangerous python2-click
BuildRequires: python3-devel python3-setuptools python3-pytest python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
%description
Flask is a lightweight WSGI web application framework. It is designed
to make getting started quick and easy, with the ability to scale up
to complex applications. It began as a simple wrapper around Werkzeug
and Jinja and has become one of the most popular Python web application
frameworks.
%package -n python2-flask
Summary: python-flask for python 2 version
%{?python_provide:%python_provide python2-flask}
Requires: python2-jinja2 python2-werkzeug python2-itsdangerous python2-click
%description -n python2-flask
Python-flask for python 2 version
%package -n python3-flask
Summary: python-flask for python 3 version
%{?python_provide:%python_provide python3-flask}
Requires: python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
%description -n python3-flask
Python-flask for python 3 version
%prep
%autosetup -n Flask-%{version} -p1
%build
%py2_build
%py3_build
%install
%py2_install
mv %{buildroot}%{_bindir}/flask{,-%{python2_version}}
ln -s flask-%{python2_version} %{buildroot}%{_bindir}/flask-2
%py3_install
mv %{buildroot}%{_bindir}/flask{,-%{python3_version}}
ln -s flask-%{python3_version} %{buildroot}%{_bindir}/flask-3
ln -sf flask-2 %{buildroot}%{_bindir}/flask
%check
export LC_ALL=C.UTF-8
PYTHONPATH=%{buildroot}%{python2_sitelib} py.test-%{python2_version} -v
PYTHONPATH=%{buildroot}%{python3_sitelib} py.test-%{python3_version} -v || :
%files -n python2-flask
%defattr(-,root,root)
%license LICENSE*
%doc CHANGES* README*
%{_bindir}/flask
%{_bindir}/flask-2
%{_bindir}/flask-%{python2_version}
%{python2_sitelib}/*
%files -n python3-flask
%defattr(-,root,root)
%license LICENSE*
%doc CHANGES* README*
%{_bindir}/flask-3
%{_bindir}/flask-%{python3_version}
%{python3_sitelib}/*
%changelog
* Fri Jan 10 2020 yangjian<yangjian79@huawei.com> - 1.0.4-3
- Change the Source to valid address
* Tue Dec 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.0.4-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/chengquanspace/python-flask.git
git@gitee.com:chengquanspace/python-flask.git
chengquanspace
python-flask
python-flask
master

搜索帮助