代码拉取完成,页面将自动刷新
同步操作将从 src-openEuler/perl-generators 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
Name: perl-generators
Version: 1.16
Release: 2.2
Summary: RPM Perl dependencies generators
License: GPL-1.0-or-later and GPL-2.0-or-later
URL: http://jplesnik.fedorapeople.org/generators
# licensed under GPL-1.0-or-later
Source0: %{url}/generators-%{version}.tar.gz
# S11:13 From Mageia: https://gitweb.mageia.org/software/rpm/rpm-setup
# with slightly modified (mageia specific code removed)
# Original licensed under GPL-2.0-or-later
Source11: perl_from_meta.attr
Source12: perl.req-from-meta
Source13: perl.recommends-from-meta
Source14: macros.perl-generators
BuildArch: noarch
BuildRequires: coreutils findutils make
BuildRequires: perl-interpreter >= 4:5.22.0
%if !%{defined perl_bootstrap}
BuildRequires: perl-generators
%endif
BuildRequires: perl(Config)
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(File::Copy)
BuildRequires: perl(File::Find)
BuildRequires: perl(strict)
BuildRequires: perl(warnings)
BuildRequires: sed
# Run-time:
BuildRequires: perl(Fedora::VSP)
BuildRequires: perl(File::Basename)
Requires: perl-interpreter >= 4:5.22.0
Requires: perl-macros
%if %{defined perl_bootstrap}
Requires: perl(Fedora::VSP)
Requires: perl(File::Basename)
%endif
Recommends: perl(version)
%description
This package provides RPM Perl dependencies generators which are used for
getting provides and requires (including recommends) from Perl binaries and modules.
%prep
%setup -q -n generators-%{version}
# Help generators to recognize Perl scripts
for F in t/*.t; do
perl -i -MConfig -ple 'print $Config{startperl} if $. == 1 && !s{\A#!.*perl\b}{$Config{startperl}}' "$F"
chmod +x "$F"
done
%build
perl Makefile.PL INSTALLDIRS=vendor INSTALLVENDORSCRIPT=%{_rpmconfigdir} \
NO_PACKLIST=1 NO_PERLLOCAL=1
%make_build
%install
%make_install
%{_fixperms} $RPM_BUILD_ROOT/*
mkdir -p %{buildroot}%{_rpmconfigdir}/fileattrs/
install -p -m 644 fileattrs/* '%{buildroot}%{_rpmconfigdir}/fileattrs'
install %{S:11} %{buildroot}%{_rpmconfigdir}/fileattrs
install %{S:12} %{S:13} %{buildroot}%{_rpmconfigdir}/
mkdir -p %{buildroot}%{_rpmconfigdir}/macros.d
install %{S:14} %{buildroot}%{_rpmconfigdir}/macros.d/
%check
make test
%files
%doc Changes TODO
%{_rpmconfigdir}/perl.*
%{_rpmconfigdir}/fileattrs/perl*.attr
%{_rpmconfigdir}/macros.d/*
%changelog
* Sat Jan 25 2025 Funda Wang <fundawang@yeah.net> - 1.16-2
- add perl_from_meta from mageia so that dependencies could be
fetched from META.json/yml
* Mon Oct 14 2024 Funda Wang <fundawang@yeah.net> - 1.16-1
- update to 1.16
* Squash multiple perl(:VERSION) symbols into one
* Remove perl dependencies that are provided in the same file
* Fix broken call to perl.prov when filenames contain spaces
* Add perltest.attr to generate dependencies for tests sub-packages
* Thu Aug 13 2020 shenyangyang <shenyangyang4@huawei.com> - 1.10-11
- Add build requires and requires of perl(Fedora::VSP) when perl bootstrap
* Thu Aug 13 2020 shenyangyang <shenyangyang4@huawei.com> - 1.10-10
- Add perl_bootstrap for perl bootstrap
* Fri Apr 03 2020 daiqianwen <daiqianwen@huawei.com> - 1.10-9
- delete useless buildrequires
* Wed Nov 27 2019 hexiaowen <hexiaowen@huawei.com> - 1.10-8
- add buildrequires perl-Test-More
* Wed Nov 27 2019 hexiaowen <hexiaowen@huawei.com> - 1.10-2
- add bootstrap
* Tue Aug 27 2019 hexiaowen <hexiaowen@huawei.com> - 1.10-1
- Package init.
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。