1 Star 0 Fork 20

huangtianhua/python-cachetools

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-cachetools.spec 2.27 KB
一键复制 编辑 原始数据 按行查看 历史
谢志鹏 提交于 2020-10-09 15:31 +08:00 . init package
%global _empty_manifest_terminate_build 0
Name: python-cachetools
Version: 4.1.1
Release: 1
Summary: Extensible memoizing collections and decorators
License: MIT
URL: https://github.com/tkem/cachetools/
Source0: https://files.pythonhosted.org/packages/fc/c8/0b52cf3132b4b85c9e83faa3e4d375575afeb3a1710c40b2b2cd2a3e5635/cachetools-4.1.1.tar.gz
BuildArch: noarch
%description
This module provides various memoizing collections and decorators,
including variants of the Python Standard Library's `@lru_cache`_
function decorator.
%package -n python3-cachetools
Summary: Extensible memoizing collections and decorators
Provides: python-cachetools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-cachetools
This module provides various memoizing collections and decorators,
including variants of the Python Standard Library's `@lru_cache`_
function decorator.
%package help
Summary: Development documents and examples for cachetools
Provides: python3-cachetools-doc
%description help
This module provides various memoizing collections and decorators,
including variants of the Python Standard Library's `@lru_cache`_
function decorator.
%prep
%autosetup -n cachetools-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cachetools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Oct 09 2020 Python_Bot <Python_Bot@openeuler.org>
- Package Spec generated
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/huangtianhua/python-cachetools.git
git@gitee.com:huangtianhua/python-cachetools.git
huangtianhua
python-cachetools
python-cachetools
master

搜索帮助