1 Star 0 Fork 3

konglidong/perl-Syntax-Keyword-Junction

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
perl-Syntax-Keyword-Junction.spec 3.09 KB
一键复制 编辑 原始数据 按行查看 历史
konglidong 提交于 2024-03-20 09:53 +08:00 . package init
# Perform optional tests
%bcond_without perl_Syntax_Keyword_Junction_enables_optional_test
Name: perl-Syntax-Keyword-Junction
Version: 0.003008
Release: 1
Summary: Perl6 style Junction operators in Perl5
License: GPL-1.0-or-later OR Artistic-1.0-Perl
URL: https://metacpan.org/release/Syntax-Keyword-Junction
Source0: https://cpan.metacpan.org/authors/id/F/FR/FREW/Syntax-Keyword-Junction-%{version}.tar.gz
BuildArch: noarch
BuildRequires: coreutils
BuildRequires: make
BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(strict)
BuildRequires: perl(warnings)
# Run-time:
BuildRequires: perl(if)
BuildRequires: perl(overload)
BuildRequires: perl(parent)
BuildRequires: perl(Sub::Exporter::Progressive) >= 0.001006
# Tests:
BuildRequires: perl(Test::More) >= 0.88
BuildRequires: perl(Test::Requires) >= 0.07
%if %{with perl_Syntax_Keyword_Junction_enables_optional_test}
# Optional tests:
BuildRequires: perl(Sub::Exporter) >= 0.986
BuildRequires: perl(syntax)
%endif
Requires: perl(if)
Requires: perl(overload)
Requires: perl(Sub::Exporter::Progressive) >= 0.001006
# Remove under-specified dependencies
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\((Sub::Exporter::Progressive|Test::More|Test::Requires)\\)$
%description
This is a lightweight module which provides 'Junction' operators, the most
commonly used being any and all. Inspired by the Perl6 design docs,
<http://dev.perl.org/perl6/doc/design/exe/E06.html>.
%package tests
Summary: Tests for %{name}
Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
Requires: perl-Test-Harness
Requires: perl(Test::More) >= 0.88
Requires: perl(Test::Requires) >= 0.07
%if %{with perl_Syntax_Keyword_Junction_enables_optional_test}
Requires: perl(if)
Requires: perl(Sub::Exporter) >= 0.986
%endif
%description tests
Tests from %{name}. Execute them
with "%{_libexecdir}/%{name}/test".
%prep
%setup -q -n Syntax-Keyword-Junction-%{version}
for F in t/release-pod-syntax.t \
%if %{without perl_Syntax_Keyword_Junction_enables_optional_test}
t/smartmatch.t t/syntax.t \
%endif
; do
rm "$F"
perl -i -ne 'print $_ unless m{^\E'"$F"'\Q}' MANIFEST
done
%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
%{make_build}
%install
%{make_install}
%{_fixperms} %{buildroot}/*
# Install tests
mkdir -p %{buildroot}%{_libexecdir}/%{name}
cp -a t %{buildroot}%{_libexecdir}/%{name}
cat > %{buildroot}%{_libexecdir}/%{name}/test << 'EOF'
#!/bin/sh
cd %{_libexecdir}/%{name} && exec prove -I . -j "$(getconf _NPROCESSORS_ONLN)"
EOF
chmod +x %{buildroot}%{_libexecdir}/%{name}/test
%check
export HARNESS_OPTIONS=j$(perl -e 'if ($ARGV[0] =~ /.*-j([0-9][0-9]*).*/) {print $1} else {print 1}' -- '%{?_smp_mflags}')
make test
%files
%license LICENSE
%doc Changes README
%{perl_vendorlib}/*
%{_mandir}/man3/*
%files tests
%{_libexecdir}/%{name}
%changelog
* Wed Mar 20 2024 konglidong <konglidong@uniontech.com> - 0.003008-1
- package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/konglidong/perl-Syntax-Keyword-Junction.git
git@gitee.com:konglidong/perl-Syntax-Keyword-Junction.git
konglidong
perl-Syntax-Keyword-Junction
perl-Syntax-Keyword-Junction
master

搜索帮助