1 Star 0 Fork 43

liqiuyu/python-flask

forked from src-openEuler/python-flask 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-flask.spec 3.72 KB
一键复制 编辑 原始数据 按行查看 历史
liqiuyu 提交于 2022-11-23 09:54 +08:00 . update version to 2.2.2
%global _empty_manifest_terminate_build 0
Name: python-flask
Version: 2.2.2
Release: 1
Summary: A lightweight WSGI web application framework
License: BSD-3-Clause
URL: https://palletsprojects.com/p/flask/
Source0: https://files.pythonhosted.org/packages/69/b6/53cfa30eed5aa7343daff36622843688ba8c6fe9829bb2b92e193ab1163f/Flask-2.2.2.tar.gz
BuildArch: noarch
Requires: python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
%description
Flask is a lightweight WSGI web application framework. It is designed
to make getting started quick and easy, with the ability to scale up
to complex applications. It began as a simple wrapper around Werkzeug
and Jinja and has become one of the most popular Python web application
frameworks.
%package -n python3-flask
Summary: A lightweight WSGI web application framework
Provides: python-flask = %{version}-%{release}
BuildRequires: python3-devel python3-setuptools python3-pytest python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
%description -n python3-flask
Flask is a lightweight WSGI web application framework. It is designed
to make getting started quick and easy, with the ability to scale up
to complex applications. It began as a simple wrapper around Werkzeug
and Jinja and has become one of the most popular Python web application
frameworks.
%package help
Summary: A lightweight WSGI web application framework
Provides: python3-flask-doc
%description help
Flask is a lightweight WSGI web application framework. It is designed
to make getting started quick and easy, with the ability to scale up
to complex applications. It began as a simple wrapper around Werkzeug
and Jinja and has become one of the most popular Python web application
frameworks.
%prep
%autosetup -n Flask-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%check
export LC_ALL=C.UTF-8
PYTHONPATH=%{buildroot}%{python3_sitelib} py.test-%{python3_version} -v || :
%files -n python3-flask -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Nov 23 2022 liqiuyu <liqiuyu@kylinos.cn> - 2.2.2-1
- Update package to version 2.2.2
* Thu Jun 23 2022 houyingchao <houyingchao@h-partners.com> - 1:2.1.2-1
- Upgrade to 2.1.2 version
* Wed May 11 2022 wulei <wulei80@h-partners.com> - 1.1.2-4
- License compliance rectification
* Wed Oct 27 2021 Haiwei Li<lihaiwei8@huawei.com> - 1.1.2-3
- backport add require pythonx-simplejson. details see issue #I4CGIS
* Thu Sep 30 2021 Jiachen Fan<fanjiachen3@huawei.com> - 1.1.2-2
- add missing install Requires python3-simplejson
* Thu Feb 04 2021 zhaorenhai <zhaorenhai@hotmail.com> - 1.1.2-1
- Upgrade version to 1.1.2
* Mon Aug 10 2020 lingsheng<lingsheng@huawei.com> - 1.0.4-4
- Remove python2-flask subpackage
* Fri Jan 10 2020 yangjian<yangjian79@huawei.com> - 1.0.4-3
- Change the Source to valid address
* Tue Dec 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.0.4-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/liqiuyu123/python-flask.git
git@gitee.com:liqiuyu123/python-flask.git
liqiuyu123
python-flask
python-flask
master

搜索帮助