登录
注册
开源
企业版
高校版
搜索
帮助中心
使用条款
关于我们
开源
企业版
高校版
私有云
模力方舟
AI 队友
登录
注册
【大赛通知】开源中国「2026北京开源行业解决方案创新赛」火热报名中,百万奖池等你的项目
代码拉取完成,页面将自动刷新
仓库状态说明
Watch
不关注
关注所有动态
仅关注版本发行动态
关注但不提醒动态
15
Star
11
Fork
109
src-openEuler
/
systemd
关闭
代码
Issues
9
Pull Requests
2
Wiki
统计
流水线
服务
JavaDoc
PHPDoc
质量分析
Jenkins for Gitee
腾讯云托管
腾讯云 Serverless
悬镜安全
阿里云 SAE
Codeblitz
SBOM
开发画像分析
我知道了,不再自动展开
更新失败,请稍后重试!
移除标识
内容风险标识
本任务被
标识为内容中包含有代码安全 Bug 、隐私泄露等敏感信息,仓库外成员不可访问
执行systemctl status超时
已完成
#I5P7T3
缺陷
我们17走
创建于
2022-09-01 15:38
<!-- #请根据issue的类型在标题右侧下拉框中选择对应的选项(需求、缺陷或CVE等)--> <!-- #请根据issue相关的版本在里程碑中选择对应的节点,若是与版本无关,请选择“不关联里程碑”--> 【标题描述】能够简要描述问题:在k8s服务器上,当系统运行pod超过一定数量,查看/proc/1/mountinfo可以看到超过1000条记录,再随机创建pod时会失败,运行systemctl status会超时 【环境信息】 硬件信息: 1) 经过复现测试,该问题在大多数linux服务器上都存在; 软件信息: 1) OpenEuler-20.03-LTS-sp1版本 2) systemd-243 【问题复现步骤】 经过分析,问题描述中创建pod会失败,是因为/proc/1/mountinfo信息条目过多,再创建pod时,由于mountinfo信息变化,导致systemctl status会超时。 通过以下方式可以复现问题: 具体操作步骤 第一步: 创建 1000 loop device [ -d /root/loopdir ] || mkdir -p /root/loopdir ; for i in $(seq 1 1000); do truncate -s 1M /root/loopdir/lo_$i.img; mkfs.ext4 /root/loopdir/lo_$i.img; mkdir /mnt/$i; echo "/root/loopdir/lo_$i.img /mnt/$i ext4 defaults,noauto 0 0" >> /etc/fstab; done 第二步: mount 挂载 for i in $(seq 1 1000); do mount /mnt/$i; done 第三步:每隔0.1秒remount while :; do mount -o remount /mnt/999; sleep 0.1; done 新起一个终端或者ssh连接,测试 systemd-run 是否超时 #date; systemd-run --scope -- echo "HELLO from the scope"; date 【预期结果】 正常情况,执行systemd-run 不会超时 【实际结果】 实际情况,执行systemd-run 会超时
<!-- #请根据issue的类型在标题右侧下拉框中选择对应的选项(需求、缺陷或CVE等)--> <!-- #请根据issue相关的版本在里程碑中选择对应的节点,若是与版本无关,请选择“不关联里程碑”--> 【标题描述】能够简要描述问题:在k8s服务器上,当系统运行pod超过一定数量,查看/proc/1/mountinfo可以看到超过1000条记录,再随机创建pod时会失败,运行systemctl status会超时 【环境信息】 硬件信息: 1) 经过复现测试,该问题在大多数linux服务器上都存在; 软件信息: 1) OpenEuler-20.03-LTS-sp1版本 2) systemd-243 【问题复现步骤】 经过分析,问题描述中创建pod会失败,是因为/proc/1/mountinfo信息条目过多,再创建pod时,由于mountinfo信息变化,导致systemctl status会超时。 通过以下方式可以复现问题: 具体操作步骤 第一步: 创建 1000 loop device [ -d /root/loopdir ] || mkdir -p /root/loopdir ; for i in $(seq 1 1000); do truncate -s 1M /root/loopdir/lo_$i.img; mkfs.ext4 /root/loopdir/lo_$i.img; mkdir /mnt/$i; echo "/root/loopdir/lo_$i.img /mnt/$i ext4 defaults,noauto 0 0" >> /etc/fstab; done 第二步: mount 挂载 for i in $(seq 1 1000); do mount /mnt/$i; done 第三步:每隔0.1秒remount while :; do mount -o remount /mnt/999; sleep 0.1; done 新起一个终端或者ssh连接,测试 systemd-run 是否超时 #date; systemd-run --scope -- echo "HELLO from the scope"; date 【预期结果】 正常情况,执行systemd-run 不会超时 【实际结果】 实际情况,执行systemd-run 会超时
评论 (
1
)
登录
后才可以发表评论
状态
已完成
待办的
已挂起
修复中
已确认
已完成
已验收
已取消
负责人
未设置
标签
sig/Base-service
未设置
项目
未立项任务
未立项任务
里程碑
未关联里程碑
未关联里程碑
Pull Requests
未关联
未关联
关联的 Pull Requests 被合并后可能会关闭此 issue
分支
未关联
分支 (
-
)
标签 (
-
)
开始日期   -   截止日期
-
置顶选项
不置顶
置顶等级:高
置顶等级:中
置顶等级:低
优先级
不指定
严重
主要
次要
不重要
预计工期
(小时)
参与者(2)
1
https://gitee.com/src-openeuler/systemd.git
git@gitee.com:src-openeuler/systemd.git
src-openeuler
systemd
systemd
点此查找更多帮助
搜索帮助
Git 命令在线学习
如何在 Gitee 导入 GitHub 仓库
Git 仓库基础操作
企业版和社区版功能对比
SSH 公钥设置
如何处理代码冲突
仓库体积过大,如何减小?
如何找回被删除的仓库数据
Gitee 产品配额说明
GitHub仓库快速导入Gitee及同步更新
什么是 Release(发行版)
将 PHP 项目自动发布到 packagist.org
仓库举报
回到顶部
登录提示
该操作需登录 Gitee 帐号,请先登录后再操作。
立即登录
没有帐号,去注册