125 Star 0 Fork 34

src-openEuler/ImageMagick

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
ImageMagick.spec 9.74 KB
一键复制 编辑 原始数据 按行查看 历史
Funda Wang 提交于 2025-03-19 22:24 +08:00 . 7.1.1-46
# Disable automatic .la file removal
%global __brp_remove_la_files %nil
Name: ImageMagick
Epoch: 1
Version: 7.1.1.46
Release: 1
Summary: Create, edit, compose, or convert bitmap images
License: ImageMagick and MIT
Url: https://www.imagemagick.org/
%global VER %(foo=%{version}; echo ${foo:0:5})
%global Patchlevel %(foo=%{version}; echo ${foo:6})
Source0: https://imagemagick.org/archive/releases/%{name}-%{VER}-%{Patchlevel}.tar.xz
BuildRequires: bzip2-devel freetype-devel libjpeg-devel libpng-devel perl-generators
BuildRequires: libtiff-devel giflib-devel zlib-devel perl-devel >= 5.8.1 jbigkit-devel
BuildRequires: libgs-devel ghostscript-x11 libwmf-devel
BuildRequires: libtool-ltdl-devel libX11-devel libXext-devel libXt-devel lcms2-devel
BuildRequires: libxml2-devel librsvg2-devel fftw-devel Imath-devel OpenEXR-devel
BuildRequires: openjpeg2-devel >= 2.1.0 libwebp-devel autoconf automake gcc gcc-c++ open-sans-fonts
Requires: open-sans-fonts
Provides: ImageMagick-libs = %{epoch}:%{version}-%{release}
Provides: ImageMagick-djva = %{epoch}:%{version}-%{release}
Obsoletes: ImageMagick-libs < %{epoch}:%{version}-%{release}
Obsoletes: ImageMagick-djvu < %{epoch}:%{version}-%{release}
%description
Use ImageMagick to create, edit, compose, or convert bitmap images. It can read and write
images in a variety of formats (over 200) including PNG, JPEG, GIF, HEIC, TIFF, DPX, EXR,
WebP, Postscript, PDF, and SVG. Use ImageMagick to resize, flip, mirror, rotate, distort,
shear and transform images, adjust image colors, apply various special effects,
or draw text, lines, polygons, ellipses and Bézier curves.
%package devel
Summary: Development files for ImageMagick
Requires: ImageMagick = %{epoch}:%{version}-%{release}
Requires: libgs-devel libX11-devel libXext-devel libXt-devel
Requires: bzip2-devel freetype-devel libtiff-devel libjpeg-devel lcms2-devel
Requires: libwebp-devel OpenEXR-devel pkgconfig
%description devel
Development files for ImageMagick.
%package help
Summary: HTML documentation for ImageMagick
Buildarch: noarch
Provides: ImageMagick-doc = %{epoch}:%{version}-%{release}
Obsoletes: ImageMagick-doc < %{epoch}:%{version}-%{release}
%description help
HTML documentation for ImageMagick.
%package perl
Summary: Perl bindings to ImageMagick
Requires: ImageMagick = %{epoch}:%{version}-%{release}
%description perl
Perl bindings to ImageMagick.
Install it to use perl scripts that use ImageMagick.
%package c++
Summary: Magick++ library
Requires: ImageMagick = %{epoch}:%{version}-%{release}
%description c++
This package contains the Magick++ library.
Install it to use applications that use Magick++.
%package c++-devel
Summary: Development files for ImageMagick-c++
Requires: ImageMagick-c++ = %{epoch}:%{version}-%{release}
Requires: ImageMagick-devel = %{epoch}:%{version}-%{release}
%description c++-devel
Development files for ImageMagick-c++.
%prep
%autosetup -n %{name}-%{VER}-%{Patchlevel} -p1
install -d Magick++/examples
cp -p Magick++/demo/*.cpp Magick++/demo/*.miff Magick++/examples
sed -e '/INSTALL_BASE/d' -i PerlMagick/Makefile.PL*
%build
autoconf -f -i
export CFLAGS="%{optflags} -DIMPNG_SETJMP_IS_THREAD_SAFE"
%configure --enable-shared --disable-static --with-modules --with-perl --with-x \
--with-threads --with-magick_plus_plus --with-gslib --with-wmf --with-webp \
--with-openexr --with-rsvg --with-xml --without-dps --without-gcc-arch \
--with-jbig --with-openjp2 \
--with-perl \
--with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
%make_build
%install
%make_install
cp -a www/source %{buildroot}%{_datadir}/doc/ImageMagick-7.1.1
rm %{buildroot}%{_libdir}/*.la
# fix weird perl module permissions
chmod 755 %{buildroot}%{perl_vendorarch}/auto/Image/Magick/Q16HDRI/Q16HDRI.so
# perlmagick: fix perl path of demo files
%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
# perlmagick: cleanup various perl tempfiles from the build which get installed
find %{buildroot} -name "*.bs" |xargs rm -f
find %{buildroot} -name ".packlist" |xargs rm -f
find %{buildroot} -name "perllocal.pod" |xargs rm -f
# perlmagick: build files list
find %{buildroot}/%{_libdir}/perl* -type f -print \
| sed "s@^%{buildroot}@@g" > perl-pkg-files
find %{buildroot}%{perl_vendorarch} -type d -print \
| sed "s@^%{buildroot}@%dir @g" \
| grep -v '^%dir %{perl_vendorarch}$' \
| grep -v '/auto$' >> perl-pkg-files
if [ -z perl-pkg-files ] ; then
echo "ERROR: EMPTY FILE LIST"
exit -1
fi
%check
export LD_LIBRARY_PATH=%{buildroot}/%{_libdir}
%make_build check
rm PerlMagick/demo/Generic.ttf
%files
%license LICENSE
%doc NOTICE AUTHORS.txt
%{_bindir}/[a-z]*
%{_libdir}/libMagickCore-7.Q16HDRI.so.10*
%{_libdir}/libMagickWand-7.Q16HDRI.so.10*
%{_libdir}/ImageMagick-7.1.1
%{_datadir}/ImageMagick-7
%dir %{_sysconfdir}/ImageMagick-7
%config(noreplace) %{_sysconfdir}/ImageMagick-7/*.xml
%files devel
%{_bindir}/MagickCore-config
%{_bindir}/MagickWand-config
%{_libdir}/libMagickCore-7.Q16HDRI.so
%{_libdir}/libMagickWand-7.Q16HDRI.so
%{_libdir}/pkgconfig/MagickCore*
%{_libdir}/pkgconfig/ImageMagick*.pc
%{_libdir}/pkgconfig/MagickWand*
%dir %{_includedir}/ImageMagick-7
%{_includedir}/%{name}-7/MagickWand
%{_includedir}/%{name}-7/MagickCore
%files help
%doc README.md
%doc %{_datadir}/doc/ImageMagick-7
%doc %{_datadir}/doc/ImageMagick-7.1.1
%{_mandir}/man?/*
%files perl -f perl-pkg-files
%doc PerlMagick/demo/ PerlMagick/Changelog PerlMagick/README.txt
%files c++
%license Magick++/LICENSE
%doc Magick++/AUTHORS
%{_libdir}/libMagick++-7.Q16HDRI.so.5*
%files c++-devel
%doc Magick++/demo
%{_bindir}/Magick++-config
%{_includedir}/ImageMagick-7/Magick++*
%{_libdir}/libMagick++-7.Q16HDRI.so
%{_libdir}/pkgconfig/Magick++*
%{_libdir}/pkgconfig/ImageMagick*
%changelog
* Wed Mar 19 2025 Funda Wang <fundawang@yeah.net> - 1:7.1.1.46-1
- update to 7.1.1-46
* Thu Mar 13 2025 Funda Wang <fundawang@yeah.net> - 1:7.1.1.45-1
- update to 7.1.1-45
* Fri Jan 03 2025 xu_ping <707078654@qq.com> - 1:7.1.1.41-1
- Update to 7.1.1-41
* Thu Jul 25 2024 Funda Wang <fundawang@yeah.net> - 1:7.1.1.35-1
- Update to 7.1.1-35
* Thu Jul 18 2024 wangkai <13474090681@163.com> - 1:7.1.1.15-2
- Fix build error for autoconf-2.72
* Mon Oct 23 2023 wulei <wu_lei@hoperun.com> - 1:7.1.1.15-1
- Update to 7.1.1.15
* Sat Oct 7 2023 liningjie <liningjie@xfusion.com> - 1:7.1.1.11-3
- Fix CVE-2023-5341
* Mon Jul 24 2023 wangkai <13474090681@163.com> - 1:7.1.1.11-2
- Fix CVE-2023-3428
* Thu Jun 08 2023 wangkai <13474090681@163.com> - 1:7.1.1.11-1
- Update to 7.1.1.11 for Fix CVE-2023-34151,CVE-2023-34153
* Mon Apr 24 2023 wangkai <13474090681@163.com> - 1:7.1.1.8-1
- Update to 7.1.1.8 for Fix CVE-2023-1289,CVE-2023-1906
* Thu Feb 09 2023 yaoxin <yaoxin30@h-partners.com> - 1:7.1.0.28-5
- Fix CVE-2022-44267,CVE-2022-44268 and CVE-2022-3213
* Tue Nov 22 2022 yaoxin <yaoxin30@h-partners.com> - 1:7.1.0.28-4
- Fix CVE-2022-32547
* Fri Aug 19 2022 cenhuilin <cenhuilin@kylinos.cn> - 1:7.1.0.28-3
- fix CVE-2022-1115
* Wed Aug 10 2022 cenhuilin <cenhuilin@kylinos.cn> - 1:7.1.0.28-2
- fix CVE-2022-2719
* Fri May 13 2022 houyingchao <houyingchao@h-partners.com> - 7.1.0.28-1
- Upgrade to 7.1.0.28 for fix CVE-2022-1114
* Thu Mar 10 2022 wangkai <wangkai385@huawei.com> - 7.1.0.27-1
- Update to 7.1.0.27 for fix CVE-2021-39212 CVE-2021-3596
* Thu Jun 03 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-25
- Fix CVE-2020-27756 CVE-2020-25667 CVE-2020-27753
* Tue May 25 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-24
- Fix CVE-2020-27769
* Thu May 20 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-23
- Fix CVE-2021-20309 CVE-2021-20311 CVE-2021-20312 CVE-2021-20313
* Thu Apr 29 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-22
- Fix CVE-2020-27752
* Mon Apr 12 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-21
- Fix CVE-2019-18853 CVE-2020-27755
* Tue Apr 6 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-20
- Fix CVE-2020-25666 CVE-2020-25675
* Wed Mar 31 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-19
- Fix CVE-2020-25676 CVE-2020-27757 CVE-2020-27758 CVE-2020-27771
CVE-2020-27772 CVE-2020-27774 CVE-2020-27775 CVE-2020-27751
* Tue Mar 23 2021 zhanghua <zhanghua40@huawei.com> - 6.9.10.67-18
- Fix CVE-2021-20246
* Sat Mar 20 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-17
- Fix CVE-2021-20244
* Tue Mar 16 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-16
- Fix CVE-2021-20241 CVE-2021-20243
* Mon Mar 8 2021 zhanghua <zhanghua40@huawei.com> - 6.9.10.67-15
- Fix CVE-2020-27750 CVE-2020-25665 CVE-2020-25674
* Wed Mar 03 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-14
- Fix CVE-2020-27768
* Mon Mar 01 2021 wangyue <wangyue92@huawei.com> - 6.9.10.67-13
- Fix CVE-2020-27773 CVE-2020-27763
* Thu Feb 25 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-12
- Fix CVE-2021-20176
* Wed Feb 10 2021 zhanghua <zhanghua40@huawei.com> - 6.9.10.67-11
- fix CVE-2020-25664 CVE-2020-27754
* Wed Jan 13 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-10
- add MIT license
* Tue Jan 12 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-9
- fix CVE-2020-29599
* Mon Jan 04 2021 wangxiao <wangxiao65@huawei.com> - 6.9.10.67-8
- fix CVE-2020-27759 CVE-2020-27760 CVE-2020-27761 CVE-2020-27762 CVE-2020-27764
CVE-2020-27765 CVE-2020-27765 CVE-2020-27766 CVE-2020-27767 CVE-2020-27770
* Sun Apr 26 2020 openEuler Buildteam <buildteam@openeuler.org> - 6.9.10.67-7
- Type:cves
- ID:CVE-2018-16329
- SUG:restart
- DESC:fix CVE-2018-16329
* Tue Mar 10 2020 songnannan <songnannan2@huawei.com> - 6.9.10.67-6
- delete the jasper
* Mon Feb 24 2020 xuxijian<xuxijian@huawei.com> - 6.9.10.67-5
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/ImageMagick.git
git@gitee.com:src-openeuler/ImageMagick.git
src-openeuler
ImageMagick
ImageMagick
master

搜索帮助