131 Star 0 Fork 7

src-openEuler/docker-compose

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
docker-compose.spec 4.38 KB
一键复制 编辑 原始数据 按行查看 历史
konglidong 提交于 2023-11-22 14:42 +08:00 . update version to 1.29.2
Name: docker-compose
Version: 1.29.2
Release: 1
Summary: Multi-container orchestration for Docker
License: ASL-2.0
URL: https://github.com/docker/compose
Source0: %pypi_source
BuildArch: noarch
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: python%{python3_pkgversion}-pytest
BuildRequires: python%{python3_pkgversion}-distro
BuildRequires: python%{python3_pkgversion}-ddt
BuildRequires: python%{python3_pkgversion}-cached_property >= 1.5.1
BuildRequires: python%{python3_pkgversion}-chardet >= 3.0.4
BuildRequires: python%{python3_pkgversion}-distro >= 1.5.0
BuildRequires: python%{python3_pkgversion}-docker >= 5.0.0
BuildRequires: python%{python3_pkgversion}-docker-pycreds >= 0.4.0
BuildRequires: python%{python3_pkgversion}-dockerpty >= 0.4.1
BuildRequires: python%{python3_pkgversion}-docopt >= 0.6.2
BuildRequires: python%{python3_pkgversion}-idna >= 2.10
BuildRequires: python%{python3_pkgversion}-jsonschema >= 3.2.0
BuildRequires: python%{python3_pkgversion}-pysocks >= 1.7.1
BuildRequires: python%{python3_pkgversion}-requests >= 2.24.0
BuildRequires: python%{python3_pkgversion}-six >= 1.12.0
BuildRequires: python%{python3_pkgversion}-texttable >= 1.6.2
BuildRequires: python%{python3_pkgversion}-websocket-client >= 0.57.0
BuildRequires: python%{python3_pkgversion}-yaml >= 5.4.1
Requires: python%{python3_pkgversion}-setuptools
Requires: python%{python3_pkgversion}-cached_property >= 1.5.1
Requires: python%{python3_pkgversion}-chardet >= 3.0.4
Requires: python%{python3_pkgversion}-distro >= 1.5.0
Requires: python%{python3_pkgversion}-docker >= 5.0.0
Requires: python%{python3_pkgversion}-docker-pycreds >= 0.4.0
Requires: python%{python3_pkgversion}-dockerpty >= 0.4.1
Requires: python%{python3_pkgversion}-docopt >= 0.6.2
Requires: python%{python3_pkgversion}-idna >= 2.10
Requires: python%{python3_pkgversion}-jsonschema >= 3.2.0
Requires: python%{python3_pkgversion}-pysocks >= 1.7.1
Requires: python%{python3_pkgversion}-requests >= 2.24.0
Requires: python%{python3_pkgversion}-six >= 1.12.0
Requires: python%{python3_pkgversion}-texttable >= 1.6.2
Requires: python%{python3_pkgversion}-websocket-client >= 0.57.0
Requires: python%{python3_pkgversion}-yaml >= 5.4.1
Requires: python%{python3_pkgversion}-attrs >= 20.3.0
Requires: python%{python3_pkgversion}-certifi >= 2020.6.20
%description
Compose is a tool for defining and running multi-container Docker
applications. With Compose, you use a Compose file to configure your
application's services. Then, using a single command, you create and
start all the services from your configuration.
Compose is great for development, testing, and staging environments,
as well as CI workflows.
Using Compose is basically a three-step process.
1. Define your app's environment with a Dockerfile so it can be
reproduced anywhere.
2. Define the services that make up your app in docker-compose.yml so
they can be run together in an isolated environment:
3. Lastly, run docker-compose up and Compose will start and run your
entire app.
%prep
%autosetup -p 1
rm -rf docker_compose.egg-info
# Remove dependency version constraints
sed -e 's/, < [0-9.]\+//' -i setup.py
%build
%py3_build
%install
%py3_install
install -D -p -m 644 contrib/completion/bash/docker-compose %{buildroot}%{_datadir}/bash-completion/completions/docker-compose
install -D -p -m 644 contrib/completion/zsh/_docker-compose %{buildroot}%{_datadir}/zsh/site-functions/_docker-compose
install -D -p -m 644 contrib/completion/fish/docker-compose.fish %{buildroot}%{_datadir}/fish/vendor_completions.d/docker-compose.fish
%files
%license LICENSE
%doc CHANGELOG.md README.md
%{_bindir}/%{name}
%{python3_sitelib}/*
%{_datadir}/bash-completion
%{_datadir}/zsh
%{_datadir}/fish
%changelog
* Wed Nov 22 2023 konglidong <konglidong@uniontech.com> - 1.29.2-1
- update version to 1.29.2
* Fri Sep 11 2020 tianwei <tianwei12@huawei.com> - 1.22.0-4
- remove irrelevant dependency version constraints
* Tue Jun 2 2020 maqiang <maqiang42@huawei.com> - 1.22.0-3
- modify the limit maximum version
* Mon Mar 2 2020 liuchao <liuchao176@huawei.com> - 1.22.0-2
- modify the limit maximum version
* Wed Sep 11 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.22.0-1
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/docker-compose.git
git@gitee.com:src-openeuler/docker-compose.git
src-openeuler
docker-compose
docker-compose
master

搜索帮助