代码拉取完成,页面将自动刷新
%global _empty_manifest_terminate_build 0
Name: python-alembic
Version: 1.14.0
Release: 1
Summary: A database migration tool for SQLAlchemy.
License: MIT
URL: https://alembic.sqlalchemy.org
Source0: https://files.pythonhosted.org/packages/source/a/alembic/alembic-%{version}.tar.gz
BuildArch: noarch
%description
Alembic is a database migrations tool written by the author of SQLAlchemy. A
migrations tool offers the following functionality:
1. Can emit ALTER statements to a database in order to change the structure of
tables and other constructs
2. Provides a system whereby "migration scripts" may be constructed; each script
indicates a particular series of steps that can "upgrade" a target database to a
new version, and optionally a series of steps that can "downgrade" similarly,
doing the same steps in reverse.
3. Allows the scripts to execute in some sequential manner.
%package -n python3-alembic
Summary: A database migration tool for SQLAlchemy.
Provides: python-alembic = %{version}-%{release}
# Base build requires
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pbr
BuildRequires: python3-pip
BuildRequires: python3-wheel
%description -n python3-alembic
Alembic is a database migrations tool written by the author of SQLAlchemy. A
migrations tool offers the following functionality:
1. Can emit ALTER statements to a database in order to change the structure of
tables and other constructs
2. Provides a system whereby "migration scripts" may be constructed; each script
indicates a particular series of steps that can "upgrade" a target database to a
new version, and optionally a series of steps that can "downgrade" similarly,
doing the same steps in reverse.
3. Allows the scripts to execute in some sequential manner.
%package help
Summary: A database migration tool for SQLAlchemy.
Provides: python3-alembic-doc
%description help
Alembic is a database migrations tool written by the author of SQLAlchemy. A
migrations tool offers the following functionality:
1. Can emit ALTER statements to a database in order to change the structure of
tables and other constructs
2. Provides a system whereby "migration scripts" may be constructed; each script
indicates a particular series of steps that can "upgrade" a target database to a
new version, and optionally a series of steps that can "downgrade" similarly,
doing the same steps in reverse.
3. Allows the scripts to execute in some sequential manner.
%prep
%autosetup -n alembic-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-alembic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Nov 7 2024 xiejing <xiejing@kylinos.cn> - 1.14.0-1
- Update package to version 1.14.0
- Added a new hook to the DefaultImpl,DefaultImpl.version_table_impl()
* Tue Oct 15 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 1.13.3-1
- Update package to version 1.13.3
- Render if_exists and if_not_exists parameters in CreateTableOp, CreateIndexOp, DropTableOp and DropIndexOp in an autogenerate context
The pin for setuptools<69.3 in pyproject.toml has been removed
* Tue Jul 30 2024 guochao <guochao@kylinos.cn> - 1.13.2-1
- Update package to version 1.13.2
- Fixes to support pytest 8.1 for the test suite
- Fixed bug in alembic command stdout where long messages were not properly wrapping at the terminal width
* Fri Feb 23 2024 jiangxinyu <jiangxinyu@kylinos.cn> - 1.13.1-1
- Update package to version 1.13.1
Improve re-writer implementation, fixing chain and adding support to callables
* Fri Nov 10 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 1.12.1-1
- Update package to version 1.12.1
* Wed Jun 21 2023 jiangxinyu <jiangxinyu@kylinos.cn> - 1.11.1-1
- Update package to version 1.11.1
* Tue May 9 2023 liyanan <thistleslyn@163.com> - 1.10.4-1
- Update package to version 1.10.4
* Tue Feb 14 2023 wubijie <wubijie@kylinos.cn> - 1.9.3-1
- Update package to version 1.9.3
* Thu Dec 15 2022 liqiuyu <liqiuyu@kylinos.cn> - 1.8.1-1
- Update package to version 1.8.1
* Tue Jul 13 2021 OpenStack_SIG <openstack@openeuler.org> - 1.5.7-1
- Upgrade to version 1.5.7
* Mon Jul 06 2020 Python_Bot <Python_Bot@openeuler.org> - 1.4.2-1
- Package Spec generated
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。