代码拉取完成,页面将自动刷新
%global srcname urllib3
%bcond_without tests
Name: python-%{srcname}
Version: 2.3.0
Release: 1
Summary: Sanity-friendly HTTP client for Python
License: MIT
URL: https://github.com/urllib3/urllib3
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
Source1: ssl_match_hostname_py3.py
BuildArch: noarch
%description
HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more.
%package -n python3-%{srcname}
Summary: Python3 HTTP library with thread-safe connection pooling and file post
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-editables
BuildRequires: python3-hatch-vcs
BuildRequires: python3-hatchling
%if %{with tests}
BuildRequires: python3-pytest
BuildRequires: python3-pytest-timeout
BuildRequires: python3-pytest-sugar
BuildRequires: python3-coverage
BuildRequires: python3-h2
BuildRequires: python3-pysocks
BuildRequires: python3-pyOpenSSL
BuildRequires: python3-idna
BuildRequires: python3-trustme
BuildRequires: python3-cryptography
BuildRequires: python3-trio
BuildRequires: python3-quart
BuildRequires: python3-quart-trio
BuildRequires: python3-hypercorn
BuildRequires: python3-httpx
%endif
Requires: ca-certificates python3-idna python3-six python3-pysocks
%description -n python3-urllib3
Python3 HTTP module with connection pooling and file POST abilities.
%prep
%autosetup -n %{srcname}-%{version} -p1
recent_date=$(date --date "7 month ago" +"%Y, %_m, %_d")
sed -i "s/^RECENT_DATE = datetime.date(.*)/RECENT_DATE = datetime.date($recent_date)/" src/urllib3/connection.py
#Failure use case circumvention
rm -rf test/with_dummyserver/
rm -rf test/appengine/
rm -rf test/contrib/
rm -rf test/test_no_ssl.py
%build
export SETUPTOOLS_SCM_PRETEND_VERSION='%{version}'
%pyproject_build
%install
%pyproject_install
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/six.py
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/__pycache__/six.*
rm -rf %{buildroot}%{python3_sitelib}/urllib3/packages/ssl_match_hostname/
mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/
mkdir -p %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
cp -a %{SOURCE1} %{buildroot}/%{python3_sitelib}/urllib3/packages/ssl_match_hostname.py
ln -s %{python3_sitelib}/six.py %{buildroot}/%{python3_sitelib}/urllib3/packages/six.py
ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.opt-1.pyc %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
ln -s %{python3_sitelib}/__pycache__/six.cpython-%{python3_version_nodots}.pyc %{buildroot}/%{python3_sitelib}/urllib3/packages/__pycache__/
%if %{with tests}
%check
# skip some failing tests
skiplist+="test_retry_deprecated or test_retry"
PYTHONPATH=%{buildroot}%{python3_sitelib}:%{python3_sitelib} %{__python3} -m pytest -v -k "not (${skiplist})"
%endif
%files -n python3-urllib3
%defattr(-,root,root)
%license LICENSE.txt
%doc CHANGES.rst README.md
%{python3_sitelib}/urllib3/
%{python3_sitelib}/urllib3-*.dist-info
%changelog
* Wed Feb 26 2025 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 2.3.0-1
- Update to 2.3.0
Added the proxy_is_tunneling property to HTTPConnection and HTTPSConnection
Added pickling support to NewConnectionError and NameResolutionError
Added support for JavaScript Promise Integration on Emscripten
Added HTTPResponse.shutdown() to stop any ongoing or future reads for a specific response
Fixed an issue in debug logs where the HTTP version was rendering as "HTTP/11" instead of "HTTP/1.1"
* Tue Jun 25 2024 chengyechun <chengyechun1@huawei.com> - 1.26.18-2
- Type:CVE
- CVE:CVE-2024-37891
- SUG:NA
- DESC:fix CVE-2024-37891 Strip Proxy-Authorizatioin header on redirects
* Tue Feb 06 2024 chengyechun <chengyechun1@huawei.com> - 1.26.18-1
- Type:enhancement
- ID:NA
- SUG:NA
- DESC:update python-urllib3 to version 1.26.18
* Tue Oct 31 2023 chengyechun <chengyechun1@huawei.com> - 1.26.17-2
- Type:CVE
- ID:CVE-2023-45803
- SUG:NA
- DESC:fix CVE-2023-45803 Made body stripped form HTTP requests
* Wed Oct 04 2023 Funda Wang <fundawang@yeah.net> - 1.26.17-1
- Update to version 1.26.17 to fix CVE-2023-43804
* Tue Aug 01 2023 chengyechun <chengyechun1@huawei.com> - 1.26.16-2
- Type:bugfix
- CVE:NA
- SUG:NA
- DESC:delete the unnecessary patch
* Mon Jul 31 2023 chengyechun <chengyechun1@huawei.com> - 1.26.16-1
- Type:enhancement
- CVE:NA
- SUG:NA
- DESC:update to 1.26.16
* Tue Jul 25 2023 chengyechun <chengyechun1@huawei.com> - 1.26.12-5
- Type:bugfix
- CVE:NA
- SUG:NA
- DESC:fix test_ssl_object_attributes
* Tue Mar 21 2023 chenhaixing <chenhaixing@huawei.com> - 1.26.12-4
- Type:bugfix
- CVE:NA
- SUG:NA
- DESC:fix socket timeout value when HTTPConnect is reused
remove Exclamation mark character from the unreserved characters
fix _idna_encode handling of x80
* Fri Feb 10 2023 chenhaixing <chenhaixing@huawei.com> - 1.26.12-3
- Type:bugfix
- CVE:NA
- SUG:NA
- DESC:change _HOST_PORT_PAT to fix port is 0 but return None
* Sat Dec 17 2022 chenhaixing <chenhaixing@huawei.com> - 1.26.12-2
- DESC:fix util.parse_url function traceback when port have leading zeros
* Sun Sep 04 2022 tianlijing <tianlijing@kylinos.cn> - 1.26.12-1
- update to 1.26.12
* Tue Aug 09 2022 chenhaixing <chenhaixing@huawei.com> - 1.26.8-2
- delete patch Bump-RECENT_DATE.patch and modify RECENT_DATE in python-urllib3.spec to adapt time change
* Mon Jul 18 2022 OpenStack_SIG <openstack@openeuler.org> - 1.26.8-1
- Upgrade package to version 1.26.8
* Wed Jul 06 2022 chenhaixing <chenhaixing@huawei.com> - 1.26.7-2
- add patch Bump RECENT_DATE and solve test case test_recent_date failed
* Wed Jan 19 2022 wangkerong <wangkerong@huawei.com> - 1.26.7-1
- update to 1.26.7 and remove python-nose dependency
* Mon Jul 5 2021 zhanzhimin <zhanzhimin@huawei.com> - 1.26.3-3
- fix CVE-2021-33503
* Tue Jun 1 2021 hanhui <hanhui15@huawei.com> - 1.26.3-2
- fix CVE-2021-28363
* Wed Feb 3 2021 chengguipeng <chengguipeng@huawei.com> - 1.26.3-1
- upgrade to 1.26.3
* Tue Jul 28 2020 chengguipeng<chengguipeng@huawei.com> - 1.25.9-1
- upgrade to 1.25.9
* Sat Oct 26 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.24.3-2
- optimize spec file.
* Mon Sep 16 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.24.3-1
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。