1 Star 0 Fork 43

刘涛/python-flask

forked from src-openEuler/python-flask 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-flask.spec 4.56 KB
一键复制 编辑 原始数据 按行查看 历史
starlet_dx 提交于 2024-12-11 14:41 +08:00 . Update to 3.1.0
%global _empty_manifest_terminate_build 0
%global pypi_name flask
Name: python-%{pypi_name}
Version: 3.1.0
Release: 1
Epoch: 1
Summary: A lightweight WSGI web application framework
License: BSD-3-Clause
URL: https://github.com/pallets/flask
Source0: %{url}/archive/%{version}/%{pypi_name}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python3-devel python3-setuptools python3-pytest python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-hatchling
BuildRequires: python3-poetry-core
BuildRequires: python3-blinker
BuildRequires: python3-flit-core
# for test
BuildRequires: python3-hypothesis
BuildRequires: python3-anyio
BuildRequires: python3-pytest
BuildRequires: python3-time-machine
BuildRequires: python3-pytest-mock
BuildRequires: python3-pytest-cov
BuildRequires: python3-pytest-rerunfailures
BuildRequires: python3-pytest-flake8
BuildRequires: python3-pytest-xdist
BuildRequires: python3-pytest-datadir
BuildRequires: python3-pytest-asyncio
BuildRequires: python3-pytest-trio
BuildRequires: python3-pytest-xprocess
BuildRequires: python3-pytest-timeout
BuildRequires: python3-pytest-benchmark
%description
Flask is a lightweight WSGI web application framework. It is designed
to make getting started quick and easy, with the ability to scale up
to complex applications. It began as a simple wrapper around Werkzeug
and Jinja and has become one of the most popular Python web application
frameworks.
%package -n python3-flask
Summary: python-flask for python 3 version
%{?python_provide:%python_provide python3-flask}
Requires: python3-jinja2 python3-werkzeug python3-itsdangerous python3-click
%description -n python3-flask
Python-flask for python 3 version
%prep
%autosetup -n flask-%{version} -p1
%build
%pyproject_build
%install
%pyproject_install
mv %{buildroot}%{_bindir}/flask{,-%{python3_version}}
ln -s flask-%{python3_version} %{buildroot}%{_bindir}/flask-3
ln -sf flask-3 %{buildroot}%{_bindir}/flask
%check
%pytest -- -Wdefault
%files -n python3-flask
%defattr(-,root,root)
%license LICENSE*
%doc CHANGES* README*
%{_bindir}/flask
%{_bindir}/flask-3
%{_bindir}/flask-%{python3_version}
%{python3_sitelib}/*
%changelog
* Wed Dec 11 2024 yaoxin <yao_xin001@hoperun.com> - 1:3.1.0-1
- Update to 3.1.0:
* Drop support for Python 3.8
* Update minimum dependency versions to latest feature releases. Werkzeug >= 3.1,
ItsDangerous >= 2.2, Blinker >= 1.9
* Provide a configuration option to control automatic option responses
* Add support for the Partitioned cookie attribute (CHIPS), with the SESSION_COOKIE_PARTITIONED config
* Support key rotation with the SECRET_KEY_FALLBACKS config, a list of old secret keys that can
still be used for unsigning. Extensions will need to add support
* Fix how setting host_matching=True or subdomain_matching=False interacts with SERVER_NAME.
Setting SERVER_NAME no longer restricts requests to only that domain
* Thu Oct 31 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 1:3.0.3-1
- Update package to version 3.0.3
Correct type for jinja_loader property.
Fix error with --extra-files and --exclude-patterns CLI options.
Fix a typo in an error message for the flask run --key option.
Restructure the code such that the Flask (app) and Blueprint classes have Sans-IO bases.
Allow self as an argument to url_for.
* Tue May 09 2023 wulei <wu_lei@hoperun.com> - 1:2.2.5-1
- Update to 2.2.5
* Fri Jan 13 2023 zhangliangpengkun<zhangliangpengkun@xfusion.com> - 1:2.1.2-3
- Fix incorrect references to query in testing doc
* Mon Jan 9 2023 zhangliangpengkun<zhangliangpengkun@xfusion.com> - 1:2.1.2-2
- Fix linting error
* Thu Jun 23 2022 houyingchao <houyingchao@h-partners.com> - 1:2.1.2-1
- Upgrade to 2.1.2 version
* Wed May 11 2022 wulei <wulei80@h-partners.com> - 1.1.2-4
- License compliance rectification
* Wed Oct 27 2021 Haiwei Li<lihaiwei8@huawei.com> - 1.1.2-3
- backport add require pythonx-simplejson. details see issue #I4CGIS
* Thu Sep 30 2021 Jiachen Fan<fanjiachen3@huawei.com> - 1.1.2-2
- add missing install Requires python3-simplejson
* Thu Feb 04 2021 zhaorenhai <zhaorenhai@hotmail.com> - 1.1.2-1
- Upgrade version to 1.1.2
* Mon Aug 10 2020 lingsheng<lingsheng@huawei.com> - 1.0.4-4
- Remove python2-flask subpackage
* Fri Jan 10 2020 yangjian<yangjian79@huawei.com> - 1.0.4-3
- Change the Source to valid address
* Tue Dec 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 1.0.4-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/xixhahahssss/python-flask.git
git@gitee.com:xixhahahssss/python-flask.git
xixhahahssss
python-flask
python-flask
master

搜索帮助