1 Star 0 Fork 10

Ya-haha/migration-tools-src

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
migration-tools.spec 5.45 KB
一键复制 编辑 原始数据 按行查看 历史
Name: migration-tools
Version: 1.0.1
Release: 14
License: MulanPSL-2.0
Summary: A tool to help users migrate the Centos system to the UOS system and openEuler system
Source0: %{name}-%{version}.tar.gz
Source1: requires.tar.gz
Source2: xlwt-1.3.0-py2.py3-none-any.whl
# patches
Patch0: 0001-use-kill-not-kill-INT-when-stop-service.patch
Patch1: 0002-modify-description.patch
Patch2: 0003-adjust-the-display-sequence.patch
Patch3: 0004-fix-cancel-button-function-in-tool.patch
Patch4: 0005-system-check-page-before-migration-displayed.patch
Patch5: 0006-return-button-after-successful-migration.patch
Patch6: 0007-user-name-input-diversity.patch
Patch7: 0008-software-source-input-box-diversity.patch
Patch8: 0009-disable-button-for-system-type-and-space.patch
Patch9: 0010-verify-user-password-disabled-by-button.patch
# CVE patches: >= 100
Patch100: 100-CVE-2024-24892.patch
BuildArch: noarch
BuildRequires: systemd
%description
UOS Migration Software
%if 0%{?rhel} >= 7
%package -n migration-tools-agent
Summary: migration-tools-agent
License: MulanPSL-2.0
Requires: dnf
Requires: libabigail
Requires: python3
Requires: python3-flask
Requires: python3-paramiko
Requires: python3-requests
Requires: python3-xlrd
Requires: python3-xlwt
Requires: openssl
Requires: rsync
Requires: yum-utils
%description -n migration-tools-agent
Migration software agent side
%endif
%package -n migration-tools-server
Summary: migration-tools-server
License: MulanPSL-2.0
Requires: python3
Requires: python3-pip
Requires: python3-paramiko
Requires: python3-flask
Requires: python3-requests
%description -n migration-tools-server
Migration software server side
%prep
%autosetup -p1
%setup -c
%if 0%{?openEuler}
cp -f %SOURCE1 %{name}-%{version}/agent-requires/
cp -f %SOURCE2 %{name}-%{version}/agent-requires/
%endif
%install
rm -rf %{buildroot}
mkdir -p $RPM_BUILD_ROOT/usr/lib/migration-tools-server
mkdir -p $RPM_BUILD_ROOT/var/tmp/uos-migration
mkdir -p $RPM_BUILD_ROOT/etc/migration-tools
mkdir -p $RPM_BUILD_ROOT%{_unitdir}
cp -r %{name}-%{version}/* $RPM_BUILD_ROOT/usr/lib/migration-tools-server/
%if 0%{?rhel} >= 7
mkdir -p $RPM_BUILD_ROOT/usr/lib/migration-tools-agent
cp -r %{name}-%{version}/* $RPM_BUILD_ROOT/usr/lib/migration-tools-agent/
%{__cp} -r $RPM_BUILD_ROOT/usr/lib/migration-tools-server/server/migration-tools-agent.service $RPM_BUILD_ROOT%{_unitdir}
%endif
# Install server config
%{__cp} -r $RPM_BUILD_ROOT/usr/lib/migration-tools-server/server/migration-tools.conf $RPM_BUILD_ROOT/etc/migration-tools
%{__cp} -r $RPM_BUILD_ROOT/usr/lib/migration-tools-server/server/migration-tools-server.service $RPM_BUILD_ROOT%{_unitdir}
%posttrans
%{_bindir}/systemctl daemon-reload
%post -n migration-tools-server
pip3 install /usr/lib/migration-tools-server/agent-requires/xlwt-1.3.0-py2.py3-none-any.whl --no-cache-dir
chmod +x /usr/lib/migration-tools-server/server/start_webview.sh
ln -sf /usr/lib/migration-tools-server/server/start_webview.sh /usr/bin/migration-tools
%preun -n migration-tools-server
if [ $1 = 0 ];then
systemctl stop migration-tools-server.service
fi
%postun -n migration-tools-server
rm -rf /usr/bin/migration-tools
%files -n migration-tools-server
/etc/migration-tools
/usr/lib/migration-tools-server
%{_unitdir}/migration-tools-server.service
%if 0%{?rhel} >= 7
%files -n migration-tools-agent
/etc/migration-tools
/usr/lib/migration-tools-agent
%{_unitdir}/migration-tools-agent.service
%endif
%changelog
* Wed Sep 11 2024 Xuezhixin <xuezhixin@uniontech.com> - 1.0.1-14
- Fix the problem of error when compiling rpm patch
* Wed Sep 04 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-13
- verify user password is disabled by button
* Wed Sep 04 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-12
- disable button for system type and space verification
* Wed Sep 04 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-11
- software source repository input field diversity
* Wed Sep 04 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-10
- user name input diversity
* Wed Sep 04 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-9
- return button after successful migration
* Fri Aug 30 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-8
- the system check page before migration is displayed
* Tue Aug 27 2024 lihaipeng <lihaipeng@uniontech.com> - 1.0.1-7
- fix cancel button function in tool
* Tue Jul 09 2024 Wenhua Huang <huangwenhua@kylinos.cn> - 1.0.1-6
- add BuildRequires systemd
* Tue Apr 02 2024 lixin <lixinb@uniontech.com> - 1.0.1-5
- adjust the display sequence
* Mon Apr 01 2024 lixin <lixinb@uniontech.com> - 1.0.1-4
- modify description
* Mon Mar 18 2024 lixin <lixinb@uniontech.com> - 1.0.1-3
- fix stop service display failed
- update spec
* Mon Mar 11 2024 lixin <lixinb@uniontech.com> - 1.0.1-2
- fix : CVE-2024-24892
- use paramiko instead of sshpass to export migration log
- and data
* Tue Mar 05 2024 lixin <lixinb@uniontech.com> - 1.0.1-1
- Supports migrations to OpenEuler system using the web-based interface.
* Wed Sep 06 2023 lixin <lixinb@uniontech.com> - 1.0.0-4
- fix: fix uefi boot failed
- fix: modify grub rules to match NIC name after migration
* Tue Aug 22 2023 lixin <lixinb@uniontech.com> - 1.0.0-3
- feat: add aarch64 agent package
* Mon Aug 21 2023 lixin <lixinb@uniontech.com> - 1.0.0-2
- fix export log and migration report error
- fix no migration detail error
* Wed Aug 16 2023 lixin <lixinb@uniontech.com> - 1.0.0-1
- init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/xuezhizone/migration-tools-src.git
git@gitee.com:xuezhizone/migration-tools-src.git
xuezhizone
migration-tools-src
migration-tools-src
master

搜索帮助