4 Star 0 Fork 3

src-openEuler/aws-sdk-cpp

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
aws-sdk-cpp.spec 2.39 KB
一键复制 编辑 原始数据 按行查看 历史
Name: aws-sdk-cpp
Version: 1.11.327
Release: 5
Summary: The AWS SDK for C++ provides a modern C++ interface for AWS
License: Apache-2.0
URL: https://github.com/aws/aws-sdk-cpp
# Source0 is generated through following steps:
# $ git clone https://github.com/aws/aws-sdk-cpp -b %%{version} --recurse-submodules --depth=1
# $ pushd aws-sdk-cpp && git-archive-all.sh --format tar --prefix aws-sdk-cpp-%%{version}/ aws-sdk-cpp-%%{version}.tar && xz aws-sdk-cpp-%%{version}.tar && popd
# where git-archive-all.sh comes from https://github.com/fabacab/git-archive-all.sh
Source0: aws-sdk-cpp-%{version}.tar.xz
Patch0: aws-sdk-cpp-1.11.327-port-to-newer-cmake.patch
BuildRequires: cmake >= 3.13
BuildRequires: gcc gcc-c++
BuildRequires: libcurl-devel
BuildRequires: openssl-devel
BuildRequires: zlib-devel
%description
The AWS SDK for C++ provides a modern C++ (version C++ 11 or later) interface
for Amazon Web Services (AWS). This package contains the S3 component.
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for %{name}.
%prep
%autosetup -p1
%build
%{cmake} \
-B %{__cmake_builddir} \
-DBUILD_ONLY="s3" \
-DCMAKE_CXX_FLAGS="%{build_cxxflags} -std=c++11 -D_GLIBCXX_USE_CXX11_ABI=0 -fstack-protector-strong" \
-DCMAKE_C_FLAGS="%{build_cflags} -std=gnu99 -D_GLIBCXX_USE_CXX11_ABI=0 -fstack-protector-strong" \
-DCMAKE_SHARED_LINKER_FLAGS="-Wl,-z,relro,-z,now %{build_ldflags}" \
-DCMAKE_SKIP_RPATH=TRUE \
-DCMAKE_BUILD_TYPE=Release \
-DAUTORUN_UNIT_TESTS=OFF \
-DENABLE_TESTING=OFF
%cmake_build
%install
%cmake_install
%files
%{_libdir}/*.so
%files devel
%{_includedir}/*
%{_libdir}/*.a
%{_libdir}/pkgconfig/*
%{_libdir}/cmake/*
%{_libdir}/*/cmake
%changelog
* Tue Mar 18 2025 lukeman <lukeman@qq.com> - 1.11.327-5
- update the method of obtaining and building the package
* Tue Mar 11 2025 Funda Wang <fundawang@yeah.net> - 1.11.327-4
- build with cmake 4.0
- aws-c-io actually needs gnu99 rather than c99
* Wed Nov 27 2024 Funda Wang <fundawang@yeah.net> - 1.11.327-3
- adopt to new cmake macro
- split out devel package
* Fri Nov 22 2024 liuheng <hengliue@163.com> - 1.11.327-2
- fix bug
* Thu Nov 7 2024 liuheng <hengliue@163.com> - 1.11.327-1
- Initial package
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/aws-sdk-cpp.git
git@gitee.com:src-openeuler/aws-sdk-cpp.git
src-openeuler
aws-sdk-cpp
aws-sdk-cpp
master

搜索帮助