9 Star 0 Fork 16

src-openEuler/libffado

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
libffado.spec 4.73 KB
一键复制 编辑 原始数据 按行查看 历史
Funda Wang 提交于 2025-04-10 19:06 +08:00 . split out ffado for loosen dependencies
%global _export_PLAGS \
export CFLAGS="%{optflags} -ffast-math" \
export CXXFLAGS="%{optflags} -ffast-math --std=gnu++11" \
export LDFLAGS="%{build_ldflags}"
Name: libffado
Version: 2.4.9
Release: 4
Summary: Free firewire audio driver library
License: GPL-2.0-only OR GPL-3.0-only
URL: https://www.ffado.org/
Source0: https://www.ffado.org/files/%{name}-%{version}.tgz
Source1: libffado-snapshot.sh
Patch1: libffado-2.4.4-icon-name.patch
BuildRequires: alsa-lib-devel dbus-c++-devel dbus-devel python3-dbus desktop-file-utils doxygen gcc-c++ glibmm24-devel
BuildRequires: graphviz libappstream-glib libconfig-devel libiec61883-devel libraw1394-devel libxml++-devel pkgconfig
BuildRequires: python3-qt5-devel python3-devel python3-enum34 python3-scons subversion
%description
The FFADO project aims to provide a universal open source solution for Linux-based FireWire-based audio device support.
It is the successor to the FreeBoB project.
%package devel
Summary: Free firewire audio driver library development headers
Requires: %{name} = %{version}-%{release}
%description devel
The libffado-devel package conatins development files to build applications for libffado.
%package -n ffado
Summary: Free firewire audio driver library applications and utilities
# support/tools/* is GPLv3
# Some files in support/mixer-qt4/ffado are GPLv3+
# The rest is GPLv2 or GPLv3
# Automatically converted from old format: GPLv3 and GPLv3+ and (GPLv2 or GPLv3) - review is highly recommended.
License: GPL-3.0-only AND GPL-3.0-or-later AND ( GPL-2.0-only OR GPL-3.0-only )
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: dbus
Requires: python3-dbus
Requires: python3-qt5
Conflicts: libffado%{?_isa} < 2.4.9-4
%description -n ffado
Applications and utilities for use with libffado.
%package_help
%prep
%autosetup -p1
%ifarch loongarch64 sw_64
%_update_config_guess
%_update_config_sub
%endif
sed -i '/Install/d' tests/{,*/}SConscript
%ifarch riscv64
# Bugs #658052
# https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5400bbb794231bb0b77f070229af2f3d95632323
sed -i -e 's/^CacheDir/#CacheDir/' SConstruct
%endif
sed -i 's|/usr/bin/.*python$|/usr/bin/python3|' admin/*.py doc/SConscript tests/python/*.py tests/*.py \
support/mixer-qt4/ffado-mixer* support/mixer-qt4/SConscript support/tools/*.py support/tools/SConscript
%build
%{_export_PLAGS}
scons %{?_smp_mflags} \
ENABLE_SETBUFFERSIZE_API_VER=True ENABLE_OPTIMIZATIONS=True CUSTOM_ENV=True BUILD_DOC=user \
PREFIX=%{_prefix} LIBDIR=%{_libdir} MANDIR=%{_mandir} UDEVDIR=%{_prefix}/lib/udev/rules.d/ \
PYPKGDIR=%{python3_sitelib}/ffado/ PYTHON_INTERPRETER=/usr/bin/python3 BUILD_TESTS=1
%install
%{_export_PLAGS}
scons DESTDIR=%{buildroot} install
install -d %{buildroot}%{_datadir}/applications
desktop-file-install --dir %{buildroot}%{_datadir}/applications --add-category="Settings" --set-icon=ffado support/xdg/org.ffado.FfadoMixer.desktop
install -m 755 tests/ffado-test %{buildroot}%{_bindir}
%check
desktop-file-validate %{buildroot}%{_datadir}/applications/org.ffado.FfadoMixer.desktop
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/org.ffado.FfadoMixer.metainfo.xml
%files
%license LICENSE.*
%doc AUTHORS ChangeLog README
%{_libdir}/libffado.so.*
%dir %{_datadir}/libffado/
%{_datadir}/libffado/configuration
%{_prefix}/lib/udev/rules.d/*
%{_libdir}/libffado
%files devel
%doc doc/reference/html/
%{_includedir}/libffado/
%{_libdir}/pkgconfig/libffado.pc
%{_libdir}/libffado.so
%files -n ffado
%{_bindir}/*
%{_datadir}/libffado/*.xml
%{_datadir}/libffado/icons/
%{_datadir}/dbus-1/services/org.ffado.Control.service
%{_datadir}/applications/org.ffado.FfadoMixer.desktop
%{_datadir}/icons/hicolor/64x64/apps/*.png
%{_datadir}/metainfo/org.ffado.FfadoMixer.metainfo.xml
%{python3_sitelib}/ffado/
%files help
%doc AUTHORS ChangeLog README
%{_mandir}/man1/ffado-*.1*
%changelog
* Thu Apr 10 2025 Funda Wang <fundawang@yeah.net> - 2.4.9-4
- split out ffado for loosen dependencies
* Thu Mar 06 2025 mahailiang <mahailiang@uniontech.com> - 2.4.9-3
- update config.guess and config.sub for sw_64
* Fri Dec 13 2024 xu_ping <707078654@qq.com> - 2.4.9-2
- fix scons-3 not found due to python3-scons upgrade.
* Tue Aug 06 2024 sqfu <dev01203@linx-info.com> - 2.4.9-1
- update version to 2.4.9.
* Thu Mar 16 2023 Wenlong Zhang<zhangwenlong@loongson.cn> - 2.4.1-8
- update config.guess and config.sub for loongarch64
* Fri Jan 07 2022 lvxiaoqian <xiaoqian@nj.iscas.ac.cn> - 2.4.1-7
- update for riscv
* Tue Oct 13 2020 maminjie <maminjie1@huawei.com> - 2.4.1-6
- Rebuilt for python3
* Tue Dec 03 2019 liujing<liujing144@huawei.com> - 2.4.1-5
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/libffado.git
git@gitee.com:src-openeuler/libffado.git
src-openeuler
libffado
libffado
master

搜索帮助