127 Star 0 Fork 18

src-openEuler/umoci

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
umoci.spec 2.32 KB
一键复制 编辑 原始数据 按行查看 历史
Hailiang 提交于 2025-03-18 17:57 +08:00 . add sw_64 support
%global debug_package %{nil}
%define tempdir github.com/openSUSE/umoci
Name: umoci
Version: 0.4.7
Release: 4
Summary: Open Container Image manipulation tool
License: ISC and MIT and Apache-2.0
URL: https://github.com/opencontainers/umoci
Source0: https://github.com/opencontainers/umoci/archive/v0.4.7.tar.gz
Source1: https://github.com/cpuguy83/go-md2man/archive/v1.0.10.tar.gz
Source2: sys.tar.gz
Patch0000: fix-bad-build-flags.patch
Patch0001: add-sw_64-support.patch
BuildRequires: fdupes go >= 1.6
%description
Umoci modifies Open Container images. Umoci intends to be a complete manipulation tool for OCI images.
In particular, it should be seen as a more end-user-focused version of the oci-image-tools provided by
the OCI.
%package_help
%prep
%autosetup -n %{name}-%{version} -p1
tar -xf %SOURCE1
%ifarch loongarch64
rm -rf vendor/golang.org/x/sys
tar -xf %{SOURCE2} -C vendor/golang.org/x
%endif
%ifarch sw_64
sed -i 's/-buildmode=pie/-buildmode=exe/g' Makefile
%endif
%build
cd go-md2man-*
go build -mod=vendor -o go-md2man .
export GO_MD2MAN=$(realpath go-md2man)
cd -
export GOPATH=$HOME/go
mkdir -pv $HOME/go/src/%{tempdir}
rm -rf $HOME/go/src/%{tempdir}/*
cp -ar * $HOME/go/src/%{tempdir}
make umoci
make docs
%install
install -D -m 0755 %{name} %{buildroot}/%{_bindir}/%{name}
%fdupes %{buildroot}
for man_file in doc/man/*.1; do
install -D -m 0644 $man_file %{buildroot}/%{_mandir}/man1/$(basename $man_file)
done
%files
%defattr(-,root,root)
%license COPYING
%{_bindir}/%{name}
%files help
%doc README.md doc/* CHANGELOG.md
%{_mandir}/man1/umoci*
%changelog
* Tue Mar 18 2025 mahailiang <mahailiang@uniontech.com> - 0.4.7-4
- add sw_64 support for umoci
* Tue Jul 11 2023 Wenlong Zhang<zhangwenlong@loongson.cn> - 0.4.7-3
- add loong64 support for umoci
* Tue Feb 15 2022 caodongxia <caodongxia@huawei.com> - 0.4.7-2
- fix bad build flags
* Tue Jan 18 2022 SimpleUpdate Robot <tc@openeuler.org> - 0.4.7-1
- Upgrade to version 0.4.7
* Fri Apr 16 2021 wangyue <wangyue92@huawei.com> - 0.4.5-5
- Fix CVE-2021-29136
* Tue Feb 9 2021 lingsheng <lingsheng@huawei.com> - 0.4.5-4
- Fix unresolvable
* Wed Sep 9 2020 Ge Wang <wangge20@huawei.com> - 0.4.5-3
- Modify Source0 Url
* Wed Mar 18 2020 openEuler Buildteam <buildteam@openeuler.org> - 0.4.5-2
- Package init
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/src-openeuler/umoci.git
git@gitee.com:src-openeuler/umoci.git
src-openeuler
umoci
umoci
master

搜索帮助